読者です 読者をやめる 読者になる 読者になる

北野坂備忘録

主にインストールやプログラミングのメモを載せています。

CentOS上のEclipseにプラグインを一気にインストールしようとして失敗

 CentOS6.7のEclipse(Helios)に下記の3プラグインを一気にインストールしようとするがエラーを起こして止まる。

・Marketplace Client
Eclipse Java EE Developer Tools
Eclipse Web Development Tools

"インストール・ダウンロード2" 中に内部エラーが発生しました。
Comparison method violates its general contract!

インストールする項目の収集中にエラーが発生しました
セッション・コンテキスト:(プロファイル=PlatformProfile、フェーズ=org.eclipse.equinox.internal.p2.engine.phases.Collect、オペランド=、アクション=)。
アーティファクトのダウンロード中に問題が発生しました: osgi.bundle,org.eclipse.wst.command.env,1.0.409.v201004211805.
MD5 ハッシュは期待されたものではありません。期待: 84614d6c0969a44318eecdc5f0dc313e で 790c9c5660db33a19040b7bafd284cc3 を検出。

 何度も失敗するので原因を調べようと、
1.Eclipse Java EE Developer Tools
2.Eclipse Web Development Tools
3.Marketplace Client

 の順に一つずつインストールすると……
 正常に終了しやがった!

 なんでさ なんでさ ななななんでさ
(士郎ラップ)

【結論】
 Eclipseプラグインのインストールは個別に行うこと。